Updated to 2.1

Updated the site.

Seems successful so far. A few of the problems I was having have been fixed by the upgrade and managed to work out a few others Spoke too soon, the stupid change of the stupid php calls for links and the merging of links with categories has screwed some things up, will fix them ASAP. FIXED. Stupid pointless changes…

The IE problem has been worked around. The problem seems to have been the MyGallery plugin I use, or more specifically the LightBox 2 scripts and css it uses. Switching it to the old lightbox has fixed things, but loses some functionality, and it’s not quite as snappy looking as lightbox 2, but better the site itself is functional than pretty pictures I guess right.

Still going to make a few more changes to the site including

  • A header graphic
  • A horizontal menu at the bottom of the header
  • Re-adding some stuff that was here before the upgrade/redesign (Amazon junk, load times and number of queries in the footer and what not)
  • Re-writing and reorganizing some of the standalone pages; about, authors, plugins used (so very, very out of date)
  • Moving all the locally hosted videos over to the wonderful (and now working with the upgrade) WordTube plugin so that they work in most browsers and spare me some bandwidth/frustration.
  • Also games and media pages eventually.
  • And of course lots more CSS /design changes, including the optional themes mentioned in the last post and some more user options such as text size, and link behavior (new window or not)

Just need some free time is all… =)

8 Comments

  1. Posted February 12, 2007 at 12:42 pm | Permalink

    hi ttan! could you help me with the my gallery plugin thingy. i uploaded the newest vsion, and installed into my wordpress, it all look ok, untill i open the my gallery page in contrlo plane…it all blank…no thing wrong at all, is just blank!

    i am using wordpress 2.1 now
    so is there any way to fixed? or can u sugges me another good gallery pluginer?

    i am so desprised for my photoblog…
    i need it working…….

    hope you could help me…
    thank you!

    ehan

  2. Posted February 12, 2007 at 2:38 pm | Permalink

    Hi Ehan,

    I can try and help, but I didn’t have any problems with MyGallery on WordPress 2.1 particularly, I had a problem with Lightbox 2 and my theme.

    I think one of the big differences between myself and the people who are having problems is that they have installed MyGallery new in 2.1, whereas I had it installed in older versions of WP and it just kept working when I updated.

    Have you tried changing themes temporarily to see if it works with a different theme? Also try disabling other plugins to see if it works then.

    There are a ton of other gallery plugins out there, but personally I have found MyGallery to be the best of the bunch for my needs. It does absolutely everything I need it to, whereas other plugins only tend to have part of the functionality I want. I just dug through http://codex.wordpress.org/Plugins/Images and I can’t find any other decent and working gallery plugins. Most are broken, have very limited functionality, or are completely abandoned by the authors.

    What features do you need from a image plugin?

    The developer says there will be a new version of MyGallery out sometime in March, but if you can’t wait I can “try” and help you troubleshoot your install. Try switching to the standard WP theme (default) and also disabling all other plugins temporarily to see if MyGallery works. If it does than the problem is either your theme, or a clash with another plugin. You can figure out which one by re-activating each of the plugins one at a time until MyGallery stops working again.

    Let me know if any of that works.

  3. Posted February 12, 2007 at 8:21 pm | Permalink

    thanks ttancm!

    currently the my gallery is the only plugin i used on my site. and i am using te deful theme…i really dont know what to say…

    and i want to try out the my gallery becuase it is a really good one + my flash together, it is just the throught photo blog elements i need..

    it there anywhere to install wordpress 2.0 or lower down my wordpress level? i know sounds silly, but i would like a try…..

    desprised!

    ehan

  4. Posted February 12, 2007 at 10:19 pm | Permalink

    Hi Ehan.

    I just took a peek at your site, but I don’t see any of the MyGallery script or CSS calls showing up in the header either.

    The site you link above is the site you are trying to use it on?

    A couple of things,
    1. If that is the site you are using it on, that is not the default WordPress theme. The theme you are using is called Easy White, the default theme can be selected by logging into your admin menu going to “Presentation” and selecting “WordPress Default 1.6” (or whatever version number) from the list of themes to see if it is a problem with the theme.

    And you would seem to be using other plugins on that site because there are style calls to something called /wp-dtree/ in your plugins directory.

    If you are having the problem on a different site can tell me the address of it so I can look at it? If you don’t want to post the address publicly you can email it to me using the contact form.

    As for lowering your WordPress version, that’s not so easy. =) If you took a database backup before upgrading to 2.1 you can downgrade, but if not then switching back to a lower version while keeping your database intact is beyond my ability.

    But I would say that should be a last ditch effort anyway. I’d try finding plugin and theme conflicts first, then possible code problems in your files, and then maybe even a problem with the PHP version on your server (apparently MyGallery has some problems with PHP5), or maybe just wait for the new version of MyGallery.

  5. Posted February 14, 2007 at 2:03 am | Permalink

    thanks ttancm, i make it works on my page now, bty, my page is gallery.ehanwu.net

    but i come up with another problem (OMG,so many problems) i installed myflash plugin, but it worked on the control plane, but it wont show many thing in my post???

    and i dont know if i made a right installed process…i installed the plug in and the foled shows like javascript, then i creat new foler called myflash and upload a imagerotator.swf into there, but on my site the flash still not work…..it appear like [myflash=tate-modern]?? anything wrong…

    plz help, i dont know whats wrong!

    thanks very much for the help above!!!
    ehan

  6. Posted February 14, 2007 at 6:21 pm | Permalink

    Hello again,

    From your description I am guessing that you have uploaded the plugin files directly to the “plugins” folder and not to the “Myflash” folder? (this seems to be the case, when I try to load http://gallery.ehanwu.net/wp-content/plugins/myflash/myflash.php I get a 404 not found error, but it loads directly from the plugins directory, so you need to move the plugin files).

    If I understand Alex’s instructions all of the plugin files need to be in the “myflash” folder (before activating, if you need to move or re-upload things, deactivate the plugin first) and then the flashrotator needs to be in the same folder with them.

  7. Posted February 16, 2007 at 4:41 am | Permalink

    OMG! WHAT I COULD SAY?! thanks so much! even i give up this flash thing, but u still helped me! and it worked on my site now!!! omg! is so nice!!!! what else i can say part from thank!!!!

    i own u a big thanks!!!!

  8. Posted February 16, 2007 at 7:09 am | Permalink

    Glad to hear it =) Let me know if there is anything else I can do. =)

preload for rolloverimage please ignore preload for rolloverimage please ignore preload for rolloverimage please ignore preload for rolloverimage please ignore preload for rolloverimage please ignore